{"answers":{"affected":"2 open source packages ship an affected version, including nodemailer.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-90776 exists.","fix":"Upgrade nodemailer to 10.0.5 or later.","what":"CVE-2026-90776 is a high-severity denial of service vulnerability in nodemailer, published on 13 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-90776 and fix it if it is affected.\n\nWhat it is: CVE-2026-90776 is a high-severity denial of service vulnerability in nodemailer, published on 13 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-90776 exists.\n\nAffected packages and fixed versions:\n- nodemailer (npm): affected from 9.1.0; fixed in 10.0.5\n- nodemailer (npm): affected from 9.1.0; fixed in 10.0.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-90776/ (Markdown: https://insights.sbomify.com/CVE-2026-90776/index.md)","id":"CVE-2026-90776","markdown":"https://insights.sbomify.com/CVE-2026-90776/index.md","name":"CVE-2026-90776","record":{"aliases":["CLEANSTART-2026-GE40690","CLEANSTART-2026-WH49536","DEBIAN-CVE-2026-90776","ECHO-61a2-f0c6-30be","GHSA-prgh-xp8r-p3m5","MINI-5v8g-5w8f-jcr8","MINI-63vm-88x5-85hw","MINI-pj89-qgg4-7wrx","ROOT-APP-NPM-CVE-2026-90776","ROOT-APP-NPM-GHSA-prgh-xp8r-p3m5","UBUNTU-CVE-2026-90776"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js email library","requires_auth":"none","summary":"Attackers can cause denial of service in Nodemailer by sending crafted email headers that trigger excessive CPU usage during address parsing.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-407","name":"Inefficient Algorithmic Complexity"}],"description":"Nodemailer versions 9.1.0 through 10.0.4 contain a quadratic time complexity vulnerability in the addressparser component when parsing email addresses with RFC 5322 comments. Attackers can craft malicious email headers with comment-separated atoms to consume excessive CPU and block the Node.js event loop for several seconds, causing denial of service.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Nodemailer 9.1.0 through 10.0.4 Denial of Service via Quadratic Address Parsing","id":"CVE-2026-90776","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":6,"next":{"headline":"ESPnet before 202609 Remote Code Execution via Unsafe Deserialization","id":"CVE-2026-90777"},"packages":[{"ecosystem":"npm","fixed":["10.0.5"],"introduced":["9.1.0"],"last_affected":[],"package":"nodemailer","purl":null,"source":"GHSA-prgh-xp8r-p3m5"},{"ecosystem":"npm","fixed":["10.0.5"],"introduced":["9.1.0"],"last_affected":[],"package":"nodemailer","purl":"pkg:npm/nodemailer","source":"GHSA-prgh-xp8r-p3m5"}],"prev":{"headline":"PostGIS address_standardizer through 3.7.0 Out-of-Bounds Read via Unvalidated Rule Weight","id":"CVE-2026-90775"},"products":["nodemailer"],"published":"2026-09-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-24","vendors":["nodemailer"]},"summary":"Attackers can cause denial of service in Nodemailer by sending crafted email headers that trigger excessive CPU usage during address parsing.","url":"https://insights.sbomify.com/CVE-2026-90776/"}