{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-90781 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2026-90781 is a medium-severity memory corruption vulnerability in alsa-lib, published on 13 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-90781 and fix it if it is affected.\n\nWhat it is: CVE-2026-90781 is a medium-severity memory corruption vulnerability in alsa-lib, published on 13 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-90781 in the wild and no public exploit code.\n\nAffected product: alsa-lib. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-90781/ (Markdown: https://insights.sbomify.com/CVE-2026-90781/index.md)","id":"CVE-2026-90781","markdown":"https://insights.sbomify.com/CVE-2026-90781/index.md","name":"CVE-2026-90781","record":{"aliases":["AZL-104928","DEBIAN-CVE-2026-90781","ECHO-5500-f7c8-e635","GHSA-f8w2-9vv9-pxwq","OESA-2026-4119","RHSA-2026:67289","UBUNTU-CVE-2026-90781","openSUSE-SU-2026:11783-1"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"ALSA audio library","requires_auth":"low_privilege","summary":"Attackers can crash applications using alsa-lib by providing long control-element identifiers, causing a stack buffer overflow.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":4.8,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-193","name":"Off-by-one Error"}],"description":"alsa-lib through 1.2.16.1 contains a stack buffer overflow in the __snd_ctl_ascii_elem_id_parse() function that writes one byte past a 64-byte buffer when parsing a name= field with 64 or more characters. Attackers can supply a long control-element identifier string through saved state files or command-line arguments to overwrite adjacent stack memory and crash the calling process.","ecosystems":["Red Hat:hummingbird:1","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":"2026-09-13","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-09-13T16:03:00Z","kind":"github_poc","ref":"https://github.com/HarshRajSinghania/CVE-2026-90781-alsa-lib-oob","stars":0,"title":"Standalone reproducer for CVE-2026-90781: 1-byte OOB write in alsa-lib __snd_ctl_ascii_elem_id_parse() name= parsing (quoted and unquoted)"}],"tier":"poc_unverified"},"has_fix":true,"headline":"alsa-lib through 1.2.16.1 Off-by-One Stack Buffer Overflow in __snd_ctl_ascii_elem_id_parse()","id":"CVE-2026-90781","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2026"},"n_packages":5,"n_references":5,"next":{"headline":"S2OPC through 1.7.3 NULL Pointer Dereference in alloc_notification_message_items()","id":"CVE-2026-90782"},"packages":[{"ecosystem":"Red Hat:hummingbird:1","fixed":["0:1.2.16.1-2.1.hum1"],"introduced":["0"],"last_affected":[],"package":"alsa-lib","purl":"pkg:rpm/redhat/alsa-lib","source":"RHSA-2026:67289"},{"ecosystem":"Red Hat:hummingbird:1","fixed":["0:1.2.16.1-2.1.hum1"],"introduced":["0"],"last_affected":[],"package":"alsa-lib-devel","purl":"pkg:rpm/redhat/alsa-lib-devel","source":"RHSA-2026:67289"},{"ecosystem":"Red Hat:hummingbird:1","fixed":["0:1.2.16.1-2.1.hum1"],"introduced":["0"],"last_affected":[],"package":"alsa-topology","purl":"pkg:rpm/redhat/alsa-topology","source":"RHSA-2026:67289"},{"ecosystem":"Red Hat:hummingbird:1","fixed":["0:1.2.16.1-2.1.hum1"],"introduced":["0"],"last_affected":[],"package":"alsa-ucm","purl":"pkg:rpm/redhat/alsa-ucm","source":"RHSA-2026:67289"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.2.16.1-2.1"],"introduced":["0"],"last_affected":[],"package":"alsa","purl":"pkg:rpm/opensuse/alsa\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:11783-1"}],"prev":{"headline":"SIPp through 3.7.7 Buffer Overflow via Oversized SIP Header Content","id":"CVE-2026-90780"},"products":["alsa-lib"],"published":"2026-09-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-16","vendors":["ALSA Project"]},"summary":"Attackers can crash applications using alsa-lib by providing long control-element identifiers, causing a stack buffer overflow.","url":"https://insights.sbomify.com/CVE-2026-90781/"}