CVE-2026-90797 Apache CouchDB: Pre-authentication gzip decompression bomb via POST /_session
High 7.7
Published
Updated
Check this codebase for CVE-2026-90797 and fix it if it is affected.
What it is: CVE-2026-90797 is a high-severity vulnerability in Apache CouchDB, published on 20 Oct 2026.
Exploitation: There is no known exploitation of CVE-2026-90797 in the wild and no public exploit code.
Affected packages and fixed versions:
- couchdb (Bitnami): affected all versions; fixed in 3.5.3
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2026-90797/ (Markdown: https://insights.sbomify.com/CVE-2026-90797/index.md)
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2026-90797?
CVE-2026-90797 is a high-severity vulnerability in Apache CouchDB, published on 20 Oct 2026.
Official description
An unlimited gzip decompression routine in chttpd in Apache CouchDB 3.5.2 and below on all platforms allows any remote client to cause a denial of service via memory exhaustion. Users are recommended to upgrade to version 3.5.3, which fixes this issue.
Weakness: CWE-409
Which versions are affected by CVE-2026-90797?
1 open source package ship an affected version, including couchdb.
| Package | Affected | Fixed in |
|---|---|---|
couchdb Bitnami | All versions | 3.5.3 |
How do I fix CVE-2026-90797?
Upgrade couchdb to 3.5.3 or later.
Is CVE-2026-90797 being exploited?
There is no known exploitation of CVE-2026-90797 in the wild and no public exploit code.
Sources
Also known as BIT-couchdb-2026-90797, GHSA-r5m6-9384-3274, UBUNTU-CVE-2026-90797.