CVE-2026-90799 Unsafe binary deserialisation in chttpd in Apache CouchDB 3.5.2 and below on all platforms allows an authenticated user to cause a denial of

Low 1.3 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2026-90799?

CVE-2026-90799 is a low-severity vulnerability in Apache CouchDB, published on 20 Oct 2026.

Official description

Unsafe binary deserialisation in chttpd in Apache CouchDB 3.5.2 and below on all platforms allows an authenticated user to cause a denial of service via memory exhaustion.

Users are recommended to upgrade to version 3.5.3, which fixes this issue.

Weakness: CWE-502

Which versions are affected by CVE-2026-90799?

1 open source package ship an affected version, including couchdb.

PackageAffectedFixed in
couchdb BitnamiAll versions3.5.3

How do I fix CVE-2026-90799?

Upgrade couchdb to 3.5.3 or later.

Is CVE-2026-90799 being exploited?

There is no known exploitation of CVE-2026-90799 in the wild and no public exploit code.

Sources

Also known as BIT-couchdb-2026-90799, GHSA-cxg8-w7xq-jwgf, UBUNTU-CVE-2026-90799.

Is CVE-2026-90799 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free