CVE-2026-90800 Apache CouchDB: Auth bypass in prefixed _users and _replicator databases

High 8.1 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2026-90800?

CVE-2026-90800 is a high-severity vulnerability in Apache CouchDB, published on 20 Oct 2026.

Official description

Missing authorisation checks in chttpd in Apache CouchDB 3.5.2 and below on all platforms allows any request to read the full contents of a prefixed _user or _replicator database via an unauthorised API endpoint.

The use of prefixed system databases is very rare.

Users are recommended to upgrade to version 3.5.3, which fixes this issue.

Weakness: CWE-862

Which versions are affected by CVE-2026-90800?

1 open source package ship an affected version, including couchdb.

PackageAffectedFixed in
couchdb BitnamiAll versions3.5.3

How do I fix CVE-2026-90800?

Upgrade couchdb to 3.5.3 or later.

Is CVE-2026-90800 being exploited?

There is no known exploitation of CVE-2026-90800 in the wild and no public exploit code.

Sources

Also known as BIT-couchdb-2026-90800, GHSA-49pc-3x56-3wp6, UBUNTU-CVE-2026-90800.

Is CVE-2026-90800 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free