{"answers":{"affected":"1 open source package ship an affected version, including couchdb.","exploited":"There is no known exploitation of CVE-2026-90800 in the wild and no public exploit code.","fix":"Upgrade couchdb to 3.5.3 or later.","what":"CVE-2026-90800 is a high-severity vulnerability in Apache CouchDB, published on 20 Oct 2026."},"fix_prompt":"Check this codebase for CVE-2026-90800 and fix it if it is affected.\n\nWhat it is: CVE-2026-90800 is a high-severity vulnerability in Apache CouchDB, published on 20 Oct 2026. \nExploitation: There is no known exploitation of CVE-2026-90800 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- couchdb (Bitnami): affected all versions; fixed in 3.5.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-90800/ (Markdown: https://insights.sbomify.com/CVE-2026-90800/index.md)","id":"CVE-2026-90800","markdown":"https://insights.sbomify.com/CVE-2026-90800/index.md","name":"CVE-2026-90800","record":{"aliases":["BIT-couchdb-2026-90800","GHSA-49pc-3x56-3wp6","UBUNTU-CVE-2026-90800"],"analysis":null,"analysis_generated_by":null,"assigner":"apache","cpe":[],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N/E:U/S:N/AU:Y/R:U/V:C/RE:M/U:Amber","version":"4.0"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"Missing authorisation checks in chttpd in Apache CouchDB 3.5.2 and below on all platforms allows any request to read the full contents of a prefixed _user or _replicator database via an unauthorised API endpoint.\n\nThe use of prefixed system databases is very rare.\n\nUsers are recommended to upgrade to version 3.5.3, which fixes this issue.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache CouchDB: Auth bypass in prefixed _users and _replicator databases","id":"CVE-2026-90800","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":null,"year":"2026"},"n_packages":1,"n_references":2,"next":{"headline":"GNU Binutils ld cache.c cache_bwrite buffer overflow","id":"CVE-2026-90801"},"packages":[{"ecosystem":"Bitnami","fixed":["3.5.3"],"introduced":["0"],"last_affected":[],"package":"couchdb","purl":"pkg:bitnami/couchdb","source":"BIT-couchdb-2026-90800"}],"prev":{"headline":"Unsafe binary deserialisation in chttpd in Apache CouchDB 3.5.2 and below on all platforms allows an authenticated user to cause a denial of","id":"CVE-2026-90799"},"products":["Apache CouchDB"],"published":"2026-10-20","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-20","vendors":["Apache Software Foundation"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2026-90800/"}