CVE-2026-90815 FFmpeg Convolution Filter vf_convolution.c setup_3x3 out-of-bounds
Remote attackers can trigger an out-of-bounds read in FFmpeg's convolution filter, potentially causing crashes or leaking memory.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-90815?
CVE-2026-90815 is a medium-severity memory corruption vulnerability in FFmpeg, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
A vulnerability has been found in FFmpeg up to 4.4.6/5.1.8/6.1.4/7.1.3/8.0.1. Affected by this issue is the function setup_3x3 of the file libavfilter/vf_convolution.c of the component Convolution Filter. Such manipulation leads to out-of-bounds read. The attack can be executed remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 4.4.7, 5.1.9, 6.1.5, 7.1.4, 8.0.2, 8.1.1 and 9.0 can resolve this issue. The name of the patch is 8970658472/e24b9820b4. It is suggested to upgrade the affected component.
Which versions are affected by CVE-2026-90815?
How do I fix CVE-2026-90815?
Upgrade to a fixed version.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2026-90815 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-90815 exists.
Sources
Also known as DEBIAN-CVE-2026-90815, GHSA-9wrf-27jr-f8f5, UBUNTU-CVE-2026-90815.