{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-90815 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2026-90815 is a medium-severity memory corruption vulnerability in FFmpeg, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-90815 and fix it if it is affected.\n\nWhat it is: CVE-2026-90815 is a medium-severity memory corruption vulnerability in FFmpeg, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-90815 exists.\n\nAffected product: FFmpeg. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-90815/ (Markdown: https://insights.sbomify.com/CVE-2026-90815/index.md)","id":"CVE-2026-90815","markdown":"https://insights.sbomify.com/CVE-2026-90815/index.md","name":"CVE-2026-90815","record":{"aliases":["DEBIAN-CVE-2026-90815","GHSA-9wrf-27jr-f8f5","UBUNTU-CVE-2026-90815"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"FFmpeg multimedia library","requires_auth":"none","summary":"Remote attackers can trigger an out-of-bounds read in FFmpeg's convolution filter, potentially causing crashes or leaking memory.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"},{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"A vulnerability has been found in FFmpeg up to 4.4.6/5.1.8/6.1.4/7.1.3/8.0.1. Affected by this issue is the function setup_3x3 of the file libavfilter/vf_convolution.c of the component Convolution Filter. Such manipulation leads to out-of-bounds read. The attack can be executed remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 4.4.7, 5.1.9, 6.1.5, 7.1.4, 8.0.2, 8.1.1 and 9.0 can resolve this issue. The name of the patch is 8970658472/e24b9820b4. It is suggested to upgrade the affected component.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"FFmpeg Convolution Filter vf_convolution.c setup_3x3 out-of-bounds","id":"CVE-2026-90815","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2026"},"n_packages":0,"n_references":7,"next":{"headline":"FFmpeg Duration hlsproto.c parse_playlist denial of service","id":"CVE-2026-90816"},"packages":[],"prev":{"headline":"cosmicstack-labs mercury-agent GitHub API github.ts githubRequest server-side request forgery","id":"CVE-2026-90814"},"products":["FFmpeg"],"published":"2026-09-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-15","vendors":["n/a"]},"summary":"Remote attackers can trigger an out-of-bounds read in FFmpeg's convolution filter, potentially causing crashes or leaking memory.","url":"https://insights.sbomify.com/CVE-2026-90815/"}