CVE-2026-9082 Drupal Core SQL Injection
Attackers can execute arbitrary SQL commands in Drupal core, potentially reading or modifying database contents.
- Exploited in the wild
- Since 22 May 2026
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-9082?
CVE-2026-9082 is a critical SQL injection vulnerability in Drupal Drupal, published on 20 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Drupal Drupal core allows SQL Injection.
This issue affects Drupal core: from 8.9.0 before 10.4.10, from 10.5.0 before 10.5.10, from 10.6.0 before 10.6.9, from 11.0.0 before 11.1.10, from 11.2.0 before 11.2.12, from 11.3.0 before 11.3.10.
Weakness: CWE-89
Which versions are affected by CVE-2026-9082?
14 open source packages ship an affected version, including drupal/core and drupal. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
drupal/core Packagist | From 10.5.0 | 10.5.10 |
drupal/core Packagist | From 10.5.0 | 10.5.10 |
drupal/core Packagist | From 10.6.0 | 10.6.9 |
drupal/core Packagist | From 10.6.0 | 10.6.9 |
drupal/core Packagist | From 11.0.0 | 11.1.10 |
drupal/core Packagist | From 11.0.0 | 11.1.10 |
8 more packages
drupal/core Packagist | From 11.2.0 | 11.2.12 |
drupal/core Packagist | From 11.2.0 | 11.2.12 |
drupal/core Packagist | From 11.3.0 | 11.3.10 |
drupal/core Packagist | From 11.3.0 | 11.3.10 |
drupal/core Packagist | From 8.9.0 | 10.4.10, 10.5.10, 10.6.9, 11.1.10, 11.2.12, 11.3.10 |
drupal/core Packagist | From 8.9.0 | 10.4.10 |
drupal/core Packagist | From 8.9.0 | 10.4.10 |
drupal Bitnami | From 8.9.0 | 10.4.10, 10.5.10, 10.6.9, 11.1.10, 11.2.12, 11.3.10 |
Products include Drupal Drupal.
How do I fix CVE-2026-9082?
Upgrade drupal/core to a fixed version for your release line: 10.5.10, 10.6.9, 11.1.10 or 11.2.12. US federal agencies must fix it by 27 May 2026.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2026-9082 being exploited?
Yes. Attackers have exploited CVE-2026-9082 in the wild since at least 22 May 2026.
Public exploit code: 1 Metasploit module, 1 Exploit-DB entry, 1 Nuclei template and 12 proofs of concept on GitHub.
Other vulnerabilities in Drupal Drupal
Sources
Also known as BIT-drupal-2026-9082, CLSA-2026-1779410881, DRUPAL-CORE-2026-004, GHSA-ghwc-95x2-682j.