# CVE-2026-9082: Drupal Core SQL Injection

> Attackers can execute arbitrary SQL commands in Drupal core, potentially reading or modifying database contents.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 22 May 2026 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 May 2026
- **Updated:** 7 Oct 2026
- **Also known as:** BIT-drupal-2026-9082, CLSA-2026-1779410881, DRUPAL-CORE-2026-004, GHSA-ghwc-95x2-682j

## What is CVE-2026-9082?

CVE-2026-9082 is a critical SQL injection vulnerability in Drupal Drupal, published on 20 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Drupal Drupal core allows SQL Injection.

This issue affects Drupal core: from 8.9.0 before 10.4.10, from 10.5.0 before 10.5.10, from 10.6.0 before 10.6.9, from 11.0.0 before 11.1.10, from 11.2.0 before 11.2.12, from 11.3.0 before 11.3.10.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-9082?

14 open source packages ship an affected version, including drupal/core and drupal. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/core` | Packagist | From 10.5.0 | 10.5.10 |
| `drupal/core` | Packagist | From 10.5.0 | 10.5.10 |
| `drupal/core` | Packagist | From 10.6.0 | 10.6.9 |
| `drupal/core` | Packagist | From 10.6.0 | 10.6.9 |
| `drupal/core` | Packagist | From 11.0.0 | 11.1.10 |
| `drupal/core` | Packagist | From 11.0.0 | 11.1.10 |
| `drupal/core` | Packagist | From 11.2.0 | 11.2.12 |
| `drupal/core` | Packagist | From 11.2.0 | 11.2.12 |
| `drupal/core` | Packagist | From 11.3.0 | 11.3.10 |
| `drupal/core` | Packagist | From 11.3.0 | 11.3.10 |
| `drupal/core` | Packagist | From 8.9.0 | 10.4.10, 10.5.10, 10.6.9, 11.1.10, 11.2.12, 11.3.10 |
| `drupal/core` | Packagist | From 8.9.0 | 10.4.10 |
| `drupal/core` | Packagist | From 8.9.0 | 10.4.10 |
| `drupal` | Bitnami | From 8.9.0 | 10.4.10, 10.5.10, 10.6.9, 11.1.10, 11.2.12, 11.3.10 |

Products: Drupal Drupal.

## How do I fix CVE-2026-9082?

Upgrade drupal/core to a fixed version for your release line: 10.5.10, 10.6.9, 11.1.10 or 11.2.12. US federal agencies must fix it by 27 May 2026.

## Is CVE-2026-9082 being exploited?

Yes. Attackers have exploited CVE-2026-9082 in the wild since at least 22 May 2026.

Public exploit code:

- Drupal Core PostgreSQL SQL Injection PoC - CVE-2026-9082. Ethical PoC for the Drupal vulnerability allowing anonymous SQL injection through the JSON:API module on PostgreSQL-backed sites. (github_poc): https://github.com/7h30th3r0n3/CVE-2026-9082-Drupal-PoC
- https://github.com/ambionics/cve-2026-9082-drupal-postgresql-rce (github_poc): https://github.com/ambionics/cve-2026-9082-drupal-postgresql-rce
- Drupal CVE-2026-9082 Blind SQL Injection Checker (github_poc): https://github.com/N45HT/drupal-cve-2026-9082-checker
- CVE-2026-9082 | SA-CORE-2026-004 (github_poc): https://github.com/HORKimhab/CVE-2026-9082
- Scanner: CVE-2026-9082 Drupal PostgreSQL SQLi via JSON:API — Python scanner for unauthenticated SQLi leading to RCE (CISA KEV) (github_poc): https://github.com/ridhinva/drupal-jsonapi-sqli-scanner
- CVE-2026-9082 (github_poc): https://github.com/0xredash/CVE-2026-9082

## Other vulnerabilities in Drupal Drupal

- [CVE-2020-13671](https://insights.sbomify.com/CVE-2020-13671/): Drupal core Un-restricted Upload of File (high 8.8, exploited in the wild)
- [CVE-2019-6340](https://insights.sbomify.com/CVE-2019-6340/): Drupal Core Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2009-3352](https://insights.sbomify.com/CVE-2009-3352/): Other in n/a (critical 10.0)
- [CVE-2024-55636](https://insights.sbomify.com/CVE-2024-55636/): Drupal core - Less critical - Gadget chain - SA-CORE-2024-006 (critical 9.8)
- [CVE-2024-55637](https://insights.sbomify.com/CVE-2024-55637/): Drupal core - Moderately critical - Gadget chain - SA-CORE-2024-007 (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-9082 and fix it if it is affected.

What it is: CVE-2026-9082 is a critical SQL injection vulnerability in Drupal Drupal, published on 20 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2026-9082 in the wild since at least 22 May 2026.

Affected packages and fixed versions:
- drupal/core (Packagist): affected from 10.5.0; fixed in 10.5.10
- drupal/core (Packagist): affected from 10.5.0; fixed in 10.5.10
- drupal/core (Packagist): affected from 10.6.0; fixed in 10.6.9
- drupal/core (Packagist): affected from 10.6.0; fixed in 10.6.9
- drupal/core (Packagist): affected from 11.0.0; fixed in 11.1.10
- drupal/core (Packagist): affected from 11.0.0; fixed in 11.1.10
- drupal/core (Packagist): affected from 11.2.0; fixed in 11.2.12
- drupal/core (Packagist): affected from 11.2.0; fixed in 11.2.12
- drupal/core (Packagist): affected from 11.3.0; fixed in 11.3.10
- drupal/core (Packagist): affected from 11.3.0; fixed in 11.3.10
- drupal/core (Packagist): affected from 8.9.0; fixed in 10.4.10, 10.5.10, 10.6.9, 11.1.10, 11.2.12, 11.3.10
- drupal/core (Packagist): affected from 8.9.0; fixed in 10.4.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-9082/ (Markdown: https://insights.sbomify.com/CVE-2026-9082/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-9082
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-9082
- OSV: https://osv.dev/vulnerability/CVE-2026-9082

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-9082/
Summaries are generated and may contain mistakes; the official description above is the record.
