# CVE-2026-90852: luben zstd-jni Dictionary Sharing ZstdCompressCtx.java ZstdCompressCtx.loadDict use after free

> A use-after-free vulnerability in zstd-jni allows remote attackers to potentially execute code or cause denial of service via dictionary sharing.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 15 Sep 2026
- **Also known as:** CLEANSTART-2026-FH00186, CLEANSTART-2026-JE63853, CLEANSTART-2026-SX37401, CLEANSTART-2026-UP93345, CLEANSTART-2026-WG76830, DEBIAN-CVE-2026-90852, GHSA-hhh7-cpvm-vxxc, UBUNTU-CVE-2026-90852

## What is CVE-2026-90852?

CVE-2026-90852 is a medium-severity use after free vulnerability in luben zstd-jni, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability has been found in luben zstd-jni up to 1.5.7-13. This vulnerability affects the function ZstdCompressCtx.loadDict of the file ZstdCompressCtx.java of the component Dictionary Sharing. Such manipulation leads to use after free. The attack can be executed remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.5.7-14 is able to resolve this issue. The name of the patch is a560131d7834598afd9cea6b7c107bc88e915936. The affected component should be upgraded. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.

Weakness: CWE-416 (Use After Free), CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2026-90852?


## How do I fix CVE-2026-90852?

Upgrade to a fixed version.

## Is CVE-2026-90852 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-90852 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-90852 and fix it if it is affected.

What it is: CVE-2026-90852 is a medium-severity use after free vulnerability in luben zstd-jni, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-90852 exists.

Affected product: luben zstd-jni. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-90852/ (Markdown: https://insights.sbomify.com/CVE-2026-90852/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-90852
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-90852
- OSV: https://osv.dev/vulnerability/CVE-2026-90852

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-90852/
Summaries are generated and may contain mistakes; the official description above is the record.
