CVE-2026-90910 Apache Answer: Reaction API authorization bypass for restricted content

Critical 9.8 Published Updated

Attackers can bypass visibility controls to read or modify reaction metadata on restricted content in Apache Answer.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-90910?

CVE-2026-90910 is a critical missing authorization vulnerability in Apache Answer, published on 19 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Missing authentication for critical function vulnerability in Apache Answer.

This issue affects Apache Answer: through 2.0.2.

The reaction API did not enforce content visibility controls, allowing unauthorized users to read reaction metadata from restricted content or add and remove their own reactions.

Users are recommended to upgrade to version 2.0.3, which fixes the issue.

Weakness: CWE-306

Which versions are affected by CVE-2026-90910?

How do I fix CVE-2026-90910?

No fix has been published for CVE-2026-90910 yet. Limit exposure of the affected software until one is available.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-90910 being exploited?

There is no known exploitation of CVE-2026-90910 in the wild and no public exploit code.

Sources

Also known as GHSA-q532-rv5p-f5vr.

Is CVE-2026-90910 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free