# CVE-2026-90910: Apache Answer: Reaction API authorization bypass for restricted content

> Attackers can bypass visibility controls to read or modify reaction metadata on restricted content in Apache Answer.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 19 Oct 2026
- **Updated:** 19 Oct 2026
- **Also known as:** GHSA-q532-rv5p-f5vr

## What is CVE-2026-90910?

CVE-2026-90910 is a critical missing authorization vulnerability in Apache Answer, published on 19 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Missing authentication for critical function vulnerability in Apache Answer.

This issue affects Apache Answer: through 2.0.2.

The reaction API did not enforce content visibility controls, allowing unauthorized users to read reaction metadata from restricted content or add and remove their own reactions.

Users are recommended to upgrade to version 2.0.3, which fixes the issue.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-90910?


## How do I fix CVE-2026-90910?

No fix has been published for CVE-2026-90910 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-90910 being exploited?

There is no known exploitation of CVE-2026-90910 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-90910 and fix it if it is affected.

What it is: CVE-2026-90910 is a critical missing authorization vulnerability in Apache Answer, published on 19 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-90910 in the wild and no public exploit code.

Affected product: Apache Answer. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-90910/ (Markdown: https://insights.sbomify.com/CVE-2026-90910/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-90910
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-90910
- OSV: https://osv.dev/vulnerability/CVE-2026-90910

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-90910/
Summaries are generated and may contain mistakes; the official description above is the record.
