# CVE-2026-90936: Froxlor before 2.3.7 Information Disclosure via customer_email.php

> Authenticated attackers can enumerate global sender alias IDs and read other customers' allowed sender values due to improper scoping in Froxlor.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 14 Sep 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-mr9h-45p9-fg8h, GHSA-wc79-h887-58h9

## What is CVE-2026-90936?

CVE-2026-90936 is a medium-severity vulnerability in froxlor, published on 14 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Froxlor before 2.3.7 fails to properly scope sender alias lookups to the current customer in customer_email.php. Authenticated attackers can enumerate global sender alias IDs and read other customers' allowed sender values by supplying arbitrary senderid parameters in delete confirmation requests.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-90936?

2 open source packages ship an affected version, including froxlor/froxlor.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `froxlor/froxlor` | Packagist | All versions | 2.3.7 |
| `froxlor/froxlor` | Packagist | All versions | 2.3.7 |

## How do I fix CVE-2026-90936?

Upgrade froxlor/froxlor to 2.3.7 or later.

## Is CVE-2026-90936 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-90936 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-90936 and fix it if it is affected.

What it is: CVE-2026-90936 is a medium-severity vulnerability in froxlor, published on 14 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-90936 exists.

Affected packages and fixed versions:
- froxlor/froxlor (Packagist): affected all versions; fixed in 2.3.7
- froxlor/froxlor (Packagist): affected all versions; fixed in 2.3.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-90936/ (Markdown: https://insights.sbomify.com/CVE-2026-90936/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-90936
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-90936
- OSV: https://osv.dev/vulnerability/CVE-2026-90936

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-90936/
Summaries are generated and may contain mistakes; the official description above is the record.
