CVE-2026-91002 stamparm maltrail Blacklist Endpoint httpd.py _blacklist missing authentication

Medium 6.9 Published Updated

Attackers can bypass authentication to access the Blacklist Endpoint in Maltrail, allowing unauthorized modification of blacklist data.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-91002?

CVE-2026-91002 is a medium-severity missing authorization vulnerability in stamparm maltrail, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A weakness has been identified in stamparm maltrail up to 3.0.1. This vulnerability affects the function _blacklist of the file core/httpd.py of the component Blacklist Endpoint. Executing a manipulation can lead to missing authentication. The attack can be launched remotely. The exploit has been made available to the public and could be used for attacks. Upgrading to version 3.1 is able to resolve this issue. This patch is called d95868dff3da4d3bd4f942837a26cb7c73a797ae. It is suggested to upgrade the affected component. The vendor fixed the issue the same day it was reported, in version 3.1, by gating the endpoint on an authenticated session or the new Blacklist_ALLOWLIST option.

Weakness: CWE-306, CWE-287

Which versions are affected by CVE-2026-91002?

How do I fix CVE-2026-91002?

No fix has been published for CVE-2026-91002 yet. Limit exposure of the affected software until one is available.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-91002 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-91002 exists.

Sources

Also known as GHSA-j5qh-4734-fxc3.

Is CVE-2026-91002 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free