{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-91002 exists.","fix":"No fix has been published for CVE-2026-91002 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-91002 is a medium-severity missing authorization vulnerability in stamparm maltrail, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-91002 and fix it if it is affected.\n\nWhat it is: CVE-2026-91002 is a medium-severity missing authorization vulnerability in stamparm maltrail, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-91002 exists.\n\nAffected product: stamparm maltrail. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-91002/ (Markdown: https://insights.sbomify.com/CVE-2026-91002/index.md)","id":"CVE-2026-91002","markdown":"https://insights.sbomify.com/CVE-2026-91002/index.md","name":"CVE-2026-91002","record":{"aliases":["GHSA-j5qh-4734-fxc3"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Maltrail threat detection","requires_auth":"none","summary":"Attackers can bypass authentication to access the Blacklist Endpoint in Maltrail, allowing unauthorized modification of blacklist data.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-306","name":"Missing Authentication for Critical Functionality"},{"id":"CWE-287","name":"Improper Authentication"}],"description":"A weakness has been identified in stamparm maltrail up to 3.0.1. This vulnerability affects the function _blacklist of the file core/httpd.py of the component Blacklist Endpoint. Executing a manipulation can lead to missing authentication. The attack can be launched remotely. The exploit has been made available to the public and could be used for attacks. Upgrading to version 3.1 is able to resolve this issue. This patch is called d95868dff3da4d3bd4f942837a26cb7c73a797ae. It is suggested to upgrade the affected component. The vendor fixed the issue the same day it was reported, in version 3.1, by gating the endpoint on an authenticated session or the new Blacklist_ALLOWLIST option.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"stamparm maltrail Blacklist Endpoint httpd.py _blacklist missing authentication","id":"CVE-2026-91002","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":0,"n_references":8,"next":{"headline":"D-Link DI-8300 CGI Service rzgl.asp rzgl_asp stack-based overflow","id":"CVE-2026-91003"},"packages":[],"prev":{"headline":"D-Link DI-8400 DDNS Configuration ddns.asp ddns_asp stack-based overflow","id":"CVE-2026-91001"},"products":["maltrail"],"published":"2026-09-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-15","vendors":["stamparm"]},"summary":"Attackers can bypass authentication to access the Blacklist Endpoint in Maltrail, allowing unauthorized modification of blacklist data.","url":"https://insights.sbomify.com/CVE-2026-91002/"}