# CVE-2026-91002: stamparm maltrail Blacklist Endpoint httpd.py _blacklist missing authentication

> Attackers can bypass authentication to access the Blacklist Endpoint in Maltrail, allowing unauthorized modification of blacklist data.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Sep 2026
- **Updated:** 15 Sep 2026
- **Also known as:** GHSA-j5qh-4734-fxc3

## What is CVE-2026-91002?

CVE-2026-91002 is a medium-severity missing authorization vulnerability in stamparm maltrail, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A weakness has been identified in stamparm maltrail up to 3.0.1. This vulnerability affects the function _blacklist of the file core/httpd.py of the component Blacklist Endpoint. Executing a manipulation can lead to missing authentication. The attack can be launched remotely. The exploit has been made available to the public and could be used for attacks. Upgrading to version 3.1 is able to resolve this issue. This patch is called d95868dff3da4d3bd4f942837a26cb7c73a797ae. It is suggested to upgrade the affected component. The vendor fixed the issue the same day it was reported, in version 3.1, by gating the endpoint on an authenticated session or the new Blacklist_ALLOWLIST option.

Weakness: CWE-306 (Missing Authentication for Critical Functionality), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-91002?


## How do I fix CVE-2026-91002?

No fix has been published for CVE-2026-91002 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-91002 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-91002 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-91002 and fix it if it is affected.

What it is: CVE-2026-91002 is a medium-severity missing authorization vulnerability in stamparm maltrail, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-91002 exists.

Affected product: stamparm maltrail. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-91002/ (Markdown: https://insights.sbomify.com/CVE-2026-91002/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-91002
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-91002
- OSV: https://osv.dev/vulnerability/CVE-2026-91002

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-91002/
Summaries are generated and may contain mistakes; the official description above is the record.
