# CVE-2026-91043: HPACK-indexed cookie fields in Mint HTTP/2 responses bypass max_header_list_size and exhaust client memory

> A malicious HTTP/2 server can exhaust client memory via HPACK-indexed cookies, causing denial of service in the Mint Elixir library.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** EEF-CVE-2026-91043, GHSA-9x8p-qrf4-jq7g

## What is CVE-2026-91043?

CVE-2026-91043 is a high-severity denial of service vulnerability in elixir-mint mint, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Allocation of Resources Without Limits or Throttling vulnerability in elixir-mint mint allows a malicious HTTP/2 server to exhaust memory on the client host and cause a denial of service.

Mint.HTTP2 enforces the client's max_header_list_size setting only on the compressed size of an inbound header block, while RFC 9113 section 6.5.2 defines the limit on the decoded header list. An HPACK indexed field costs one byte on the wire and decodes to a dynamic table entry of up to 4 KB, and join_cookie_headers/1 in lib/mint/http2.ex copies every cookie value of a response into one new binary. A header block under the default 256 KB wire limit therefore makes the client allocate about 1 GB for a single response, and several such responses in one delivery exhaust the memory of the process that owns the connection or of the whole VM.

This issue affects mint: from 1.1.0 before 1.10.2.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-91043?

1 open source package ship an affected version, including mint.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mint` | Hex | From 1.1.0 | 1.10.2 |

## How do I fix CVE-2026-91043?

Upgrade mint to 1.10.2 or later.

## Is CVE-2026-91043 being exploited?

There is no known exploitation of CVE-2026-91043 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-91043 and fix it if it is affected.

What it is: CVE-2026-91043 is a high-severity denial of service vulnerability in elixir-mint mint, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-91043 in the wild and no public exploit code.

Affected packages and fixed versions:
- mint (Hex): affected from 1.1.0; fixed in 1.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-91043/ (Markdown: https://insights.sbomify.com/CVE-2026-91043/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-91043
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-91043
- OSV: https://osv.dev/vulnerability/CVE-2026-91043

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-91043/
Summaries are generated and may contain mistakes; the official description above is the record.
