# CVE-2026-91119: Discourse: Encode action_code_who in mention URLs

> Attackers can inject malicious HTML into Discourse activity logs via unencoded user names, potentially executing scripts in other users' browsers.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Sep 2026
- **Updated:** 28 Sep 2026
- **Also known as:** BIT-discourse-2026-91119, GHSA-pv3p-p3m9-v8v3

## What is CVE-2026-91119?

CVE-2026-91119 is a medium-severity cross-site scripting vulnerability in discourse, published on 24 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Discourse is an open-source discussion platform. Prior to 2026.1.8, 2026.6.3, 2026.7.2, and 2026.8.0, the topic small-action and nested-activity-log components interpolated the free-form action_code_who value into mention-link href attributes without URL encoding. A quote-bearing display name could terminate the intended URL attribute and inject attacker-controlled elements into the trusted rendered markup. Although the visible mention text was escaped, the unencoded path component allowed stored HTML injection when another user viewed the affected topic action or activity log. This issue is fixed in versions 2026.1.8, 2026.6.3, 2026.7.2, and 2026.8.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-91119?

1 open source package ship an affected version, including discourse.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 2026.8.0 |

## How do I fix CVE-2026-91119?

Upgrade discourse to 2026.8.0 or later.

## Is CVE-2026-91119 being exploited?

There is no known exploitation of CVE-2026-91119 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-91119 and fix it if it is affected.

What it is: CVE-2026-91119 is a medium-severity cross-site scripting vulnerability in discourse, published on 24 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-91119 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 2026.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-91119/ (Markdown: https://insights.sbomify.com/CVE-2026-91119/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-91119
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-91119
- OSV: https://osv.dev/vulnerability/CVE-2026-91119

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-91119/
Summaries are generated and may contain mistakes; the official description above is the record.
