{"answers":{"affected":"1 open source package ship an affected version, including discourse.","exploited":"There is no known exploitation of CVE-2026-91123 in the wild and no public exploit code.","fix":"Upgrade discourse to 2026.8.0 or later.","what":"CVE-2026-91123 is a high-severity path traversal vulnerability in discourse, published on 24 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-91123 and fix it if it is affected.\n\nWhat it is: CVE-2026-91123 is a high-severity path traversal vulnerability in discourse, published on 24 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-91123 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- discourse (Bitnami): affected all versions; fixed in 2026.8.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-91123/ (Markdown: https://insights.sbomify.com/CVE-2026-91123/index.md)","id":"CVE-2026-91123","markdown":"https://insights.sbomify.com/CVE-2026-91123/index.md","name":"CVE-2026-91123","record":{"aliases":["BIT-discourse-2026-91123","GHSA-6pwj-wgg8-4rjc"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Discourse forum","requires_auth":"none","summary":"Attackers can bypass iframe path restrictions using backslashes to load unauthorized content, requiring administrators to upgrade Discourse.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Discourse is an open-source discussion platform. Prior to 2026.1.8, 2026.6.3, 2026.7.2, and 2026.8.0, the iframe src traversal guard did not treat literal backslashes as path separators after decoded dot segments. A crafted source could therefore pass an allowed_iframes subpath check while browser URL normalization moved the iframe outside the intended allowed path. The resulting iframe could load content from a location that the administrator did not allow. This issue is fixed in versions 2026.1.8, 2026.6.3, 2026.7.2, and 2026.8.0.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Discourse: Reject literal backslash path separators in iframe src traversal guard","id":"CVE-2026-91123","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":1,"n_references":6,"next":{"headline":"File Viewer: DOM XSS via unsafe hyperlink schemes in the legacy DOC renderer","id":"CVE-2026-91127"},"packages":[{"ecosystem":"Bitnami","fixed":["2026.8.0"],"introduced":["0"],"last_affected":[],"package":"discourse","purl":"pkg:bitnami/discourse","source":"BIT-discourse-2026-91123"}],"prev":{"headline":"Discourse: Chat MessageBus delivers read-restricted messages to unauthorized users","id":"CVE-2026-91122"},"products":["discourse"],"published":"2026-09-24","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-24","vendors":["discourse"]},"summary":"Attackers can bypass iframe path restrictions using backslashes to load unauthorized content, requiring administrators to upgrade Discourse.","url":"https://insights.sbomify.com/CVE-2026-91123/"}