# CVE-2026-91123: Discourse: Reject literal backslash path separators in iframe src traversal guard

> Attackers can bypass iframe path restrictions using backslashes to load unauthorized content, requiring administrators to upgrade Discourse.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Sep 2026
- **Updated:** 24 Sep 2026
- **Also known as:** BIT-discourse-2026-91123, GHSA-6pwj-wgg8-4rjc

## What is CVE-2026-91123?

CVE-2026-91123 is a high-severity path traversal vulnerability in discourse, published on 24 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Discourse is an open-source discussion platform. Prior to 2026.1.8, 2026.6.3, 2026.7.2, and 2026.8.0, the iframe src traversal guard did not treat literal backslashes as path separators after decoded dot segments. A crafted source could therefore pass an allowed_iframes subpath check while browser URL normalization moved the iframe outside the intended allowed path. The resulting iframe could load content from a location that the administrator did not allow. This issue is fixed in versions 2026.1.8, 2026.6.3, 2026.7.2, and 2026.8.0.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-91123?

1 open source package ship an affected version, including discourse.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 2026.8.0 |

## How do I fix CVE-2026-91123?

Upgrade discourse to 2026.8.0 or later.

## Is CVE-2026-91123 being exploited?

There is no known exploitation of CVE-2026-91123 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-91123 and fix it if it is affected.

What it is: CVE-2026-91123 is a high-severity path traversal vulnerability in discourse, published on 24 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-91123 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 2026.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-91123/ (Markdown: https://insights.sbomify.com/CVE-2026-91123/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-91123
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-91123
- OSV: https://osv.dev/vulnerability/CVE-2026-91123

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-91123/
Summaries are generated and may contain mistakes; the official description above is the record.
