CVE-2026-91127 File Viewer: DOM XSS via unsafe hyperlink schemes in the legacy DOC renderer

High 8.2 Published Updated

Attackers can execute arbitrary JavaScript in the embedding application's origin by tricking users into clicking malicious links in crafted DOC files.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-91127?

CVE-2026-91127 is a high-severity cross-site scripting vulnerability in @file-viewer doc, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

File Viewer is a browser-native viewer for Office, PDF, CAD, archive, and other files in private and internal web applications. Prior to @file-viewer/doc 2.3.1 and msdoc-viewer 0.2.2, the legacy DOC renderer emitted document-controlled hyperlink targets into generated HTML after character escaping but without restricting URL schemes. A crafted legacy DOC file could place javascript:, vbscript:, data:, or another unsafe scheme in a rendered link, and script could execute in the embedding application's origin when a user clicked the link. The fix blocks external document links by default, allows only HTTP(S), mail, telephone, safe relative URLs, and internal bookmarks when external links are explicitly enabled, and applies mount-boundary sanitization as defense in depth. This issue is fixed in @file-viewer/doc 2.3.1 and msdoc-viewer 0.2.2.

Weakness: CWE-83, CWE-79

Which versions are affected by CVE-2026-91127?

4 open source packages ship an affected version, including @file-viewer/doc and msdoc-viewer.

PackageAffectedFixed in
@file-viewer/doc npmAll versions2.3.1
@file-viewer/doc npmAll versions2.3.1
msdoc-viewer npmAll versions0.2.2
msdoc-viewer npmAll versions0.2.2

How do I fix CVE-2026-91127?

Upgrade @file-viewer/doc to 2.3.1 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-91127 being exploited?

There is no known exploitation of CVE-2026-91127 in the wild and no public exploit code.

Sources

Also known as GHSA-3753-m2x2-q623.

Is CVE-2026-91127 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free