# CVE-2026-91129: Home Assistant: mDNS Server-Side Request Forgery


- **Severity:** Medium 5.4 (`CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 22 Sep 2026
- **Updated:** 24 Sep 2026
- **Also known as:** GHSA-4ghv-53cq-7wp3, PYSEC-2026-4051

## What is CVE-2026-91129?

CVE-2026-91129 is a medium-severity vulnerability in home-assistant core, published on 22 Sep 2026. 

### Official description

Home Assistant is open source home automation software focused on local control and privacy. Prior to 2026.2.3, the IPP integration automatically processed unauthenticated _ipp._tcp.local mDNS announcements in homeassistant/components/ipp/config_flow.py, where async_step_zeroconf passed attacker-controlled host, port, and base_path values to validate_input for printer metadata retrieval. Because the shared HTTP client followed attacker-controlled cross-origin redirects without blocking loopback targets, a local-network attacker could redirect the request to 127.0.0.1 or another internal service without user interaction or prior IPP configuration. This issue is fixed in version 2026.2.3.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-91129?

3 open source packages ship an affected version, including homeassistant.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `homeassistant` | PyPI | All versions | 2026.2.3 |
| `homeassistant` | PyPI | All versions | 2026.2.3 |
| `homeassistant` | PyPI | All versions | 2026.2.3 |

## How do I fix CVE-2026-91129?

Upgrade homeassistant to 2026.2.3 or later.

## Is CVE-2026-91129 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-91129 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-91129 and fix it if it is affected.

What it is: CVE-2026-91129 is a medium-severity vulnerability in home-assistant core, published on 22 Sep 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-91129 exists.

Affected packages and fixed versions:
- homeassistant (PyPI): affected all versions; fixed in 2026.2.3
- homeassistant (PyPI): affected all versions; fixed in 2026.2.3
- homeassistant (PyPI): affected all versions; fixed in 2026.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-91129/ (Markdown: https://insights.sbomify.com/CVE-2026-91129/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-91129
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-91129
- OSV: https://osv.dev/vulnerability/CVE-2026-91129

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-91129/
Summaries are generated and may contain mistakes; the official description above is the record.
