CVE-2026-91132 Discourse: Wildcard iframe origin allowlist bypass via authority separators
Attackers can bypass iframe origin allowlists in Discourse by exploiting wildcard pattern parsing flaws, allowing unauthorized content rendering.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-91132?
CVE-2026-91132 is a medium-severity vulnerability in discourse, published on 24 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Discourse is an open-source discussion platform. Prior to 2026.1.8, 2026.6.3, 2026.7.2, and 2026.8.0, sites using wildcard patterns in the allowed_iframes setting could accept a crafted iframe URL whose allowlisted suffix appeared after a URL authority separator. The wildcard origin check matched the allowed domain text, while browser URL parsing selected a different attacker-controlled origin. A user with posting privileges could exploit the flaw through a post or a Onebox oEmbed response and cause an attacker-controlled iframe to be rendered independently of the allowlisted domain. Successful exploitation requires a site-configured wildcard iframe pattern and the ability to create a post or trigger an oEmbed request for an attacker-controlled URL. This issue is fixed in versions 2026.1.8, 2026.6.3, 2026.7.2, and 2026.8.0.
Weakness: CWE-346
Which versions are affected by CVE-2026-91132?
1 open source package ship an affected version, including discourse.
| Package | Affected | Fixed in |
|---|---|---|
discourse Bitnami | All versions | 2026.8.0 |
How do I fix CVE-2026-91132?
Upgrade discourse to 2026.8.0 or later.
Is CVE-2026-91132 being exploited?
There is no known exploitation of CVE-2026-91132 in the wild and no public exploit code.
Sources
Also known as BIT-discourse-2026-91132, GHSA-4q3q-hph3-3rvp.