{"answers":{"affected":"1 open source package ship an affected version, including discourse.","exploited":"There is no known exploitation of CVE-2026-91132 in the wild and no public exploit code.","fix":"Upgrade discourse to 2026.8.0 or later.","what":"CVE-2026-91132 is a medium-severity vulnerability in discourse, published on 24 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-91132 and fix it if it is affected.\n\nWhat it is: CVE-2026-91132 is a medium-severity vulnerability in discourse, published on 24 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-91132 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- discourse (Bitnami): affected all versions; fixed in 2026.8.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-91132/ (Markdown: https://insights.sbomify.com/CVE-2026-91132/index.md)","id":"CVE-2026-91132","markdown":"https://insights.sbomify.com/CVE-2026-91132/index.md","name":"CVE-2026-91132","record":{"aliases":["BIT-discourse-2026-91132","GHSA-4q3q-hph3-3rvp"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Discourse forum","requires_auth":"low_privilege","summary":"Attackers can bypass iframe origin allowlists in Discourse by exploiting wildcard pattern parsing flaws, allowing unauthorized content rendering.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-346","name":"Origin Validation Error"}],"description":"Discourse is an open-source discussion platform. Prior to 2026.1.8, 2026.6.3, 2026.7.2, and 2026.8.0, sites using wildcard patterns in the allowed_iframes setting could accept a crafted iframe URL whose allowlisted suffix appeared after a URL authority separator. The wildcard origin check matched the allowed domain text, while browser URL parsing selected a different attacker-controlled origin. A user with posting privileges could exploit the flaw through a post or a Onebox oEmbed response and cause an attacker-controlled iframe to be rendered independently of the allowlisted domain. Successful exploitation requires a site-configured wildcard iframe pattern and the ability to create a post or trigger an oEmbed request for an attacker-controlled URL. This issue is fixed in versions 2026.1.8, 2026.6.3, 2026.7.2, and 2026.8.0.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Discourse: Wildcard iframe origin allowlist bypass via authority separators","id":"CVE-2026-91132","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"security_feature_bypass","year":"2026"},"n_packages":1,"n_references":6,"next":{"headline":"Discourse: Escape LIKE metacharacters in upload paths to prevent disclosure","id":"CVE-2026-91133"},"packages":[{"ecosystem":"Bitnami","fixed":["2026.8.0"],"introduced":["0"],"last_affected":[],"package":"discourse","purl":"pkg:bitnami/discourse","source":"BIT-discourse-2026-91132"}],"prev":{"headline":"Home Assistant: XSS in Statistics Graph Card","id":"CVE-2026-91130"},"products":["discourse"],"published":"2026-09-24","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-29","vendors":["discourse"]},"summary":"Attackers can bypass iframe origin allowlists in Discourse by exploiting wildcard pattern parsing flaws, allowing unauthorized content rendering.","url":"https://insights.sbomify.com/CVE-2026-91132/"}