# CVE-2026-91132: Discourse: Wildcard iframe origin allowlist bypass via authority separators

> Attackers can bypass iframe origin allowlists in Discourse by exploiting wildcard pattern parsing flaws, allowing unauthorized content rendering.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** BIT-discourse-2026-91132, GHSA-4q3q-hph3-3rvp

## What is CVE-2026-91132?

CVE-2026-91132 is a medium-severity vulnerability in discourse, published on 24 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Discourse is an open-source discussion platform. Prior to 2026.1.8, 2026.6.3, 2026.7.2, and 2026.8.0, sites using wildcard patterns in the allowed_iframes setting could accept a crafted iframe URL whose allowlisted suffix appeared after a URL authority separator. The wildcard origin check matched the allowed domain text, while browser URL parsing selected a different attacker-controlled origin. A user with posting privileges could exploit the flaw through a post or a Onebox oEmbed response and cause an attacker-controlled iframe to be rendered independently of the allowlisted domain. Successful exploitation requires a site-configured wildcard iframe pattern and the ability to create a post or trigger an oEmbed request for an attacker-controlled URL. This issue is fixed in versions 2026.1.8, 2026.6.3, 2026.7.2, and 2026.8.0.

Weakness: CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2026-91132?

1 open source package ship an affected version, including discourse.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 2026.8.0 |

## How do I fix CVE-2026-91132?

Upgrade discourse to 2026.8.0 or later.

## Is CVE-2026-91132 being exploited?

There is no known exploitation of CVE-2026-91132 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-91132 and fix it if it is affected.

What it is: CVE-2026-91132 is a medium-severity vulnerability in discourse, published on 24 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-91132 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 2026.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-91132/ (Markdown: https://insights.sbomify.com/CVE-2026-91132/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-91132
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-91132
- OSV: https://osv.dev/vulnerability/CVE-2026-91132

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-91132/
Summaries are generated and may contain mistakes; the official description above is the record.
