# CVE-2026-91134: Discourse: Block post iframes whose encoded userinfo bypasses the allowed_iframes allowlist

> Authenticated users can bypass iframe allowlists via encoded userinfo, injecting malicious cross-origin content into posts.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** BIT-discourse-2026-91134, GHSA-54vw-chv3-wjpv

## What is CVE-2026-91134?

CVE-2026-91134 is a medium-severity cross-site scripting vulnerability in discourse, published on 24 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Discourse is an open-source discussion platform. Prior to 2026.1.8, 2026.6.3, 2026.7.2, and 2026.8.0, the Discourse post sanitizer allowed a stored cross-origin iframe to bypass the allowed_iframes prefix policy when the iframe src contained encoded userinfo. The sanitizer validated a decoded form differently from the stored iframe src, allowing the browser to interpret an attacker-controlled host while the allowlist check accepted the encoded URL as an allowed prefix. An authenticated user with posting privileges could persist the iframe in a post and cause attacker-controlled cross-origin content to be rendered. This issue is fixed in versions 2026.1.8, 2026.6.3, 2026.7.2, and 2026.8.0.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-91134?

1 open source package ship an affected version, including discourse.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 2026.8.0 |

## How do I fix CVE-2026-91134?

Upgrade discourse to 2026.8.0 or later.

## Is CVE-2026-91134 being exploited?

There is no known exploitation of CVE-2026-91134 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-91134 and fix it if it is affected.

What it is: CVE-2026-91134 is a medium-severity cross-site scripting vulnerability in discourse, published on 24 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-91134 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 2026.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-91134/ (Markdown: https://insights.sbomify.com/CVE-2026-91134/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-91134
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-91134
- OSV: https://osv.dev/vulnerability/CVE-2026-91134

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-91134/
Summaries are generated and may contain mistakes; the official description above is the record.
