# CVE-2026-91135: Apache Thrift: C++ `THeaderTransport::transform()` heap buffer overflow (write direction)

> A heap buffer overflow in Apache Thrift C++ allows remote attackers to execute code or cause denial of service when ZLIB compression is enabled.

- **Severity:** Critical 9.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Oct 2026
- **Updated:** 2 Oct 2026
- **Also known as:** AZL-105425, BIT-thrift-2026-91135, DEBIAN-CVE-2026-91135, ECHO-f016-0b10-74ab, GHSA-3gv9-wqfp-2rf3, MINI-2x62-3hqx-jjhq, UBUNTU-CVE-2026-91135

## What is CVE-2026-91135?

CVE-2026-91135 is a critical memory corruption vulnerability in Apache Thrift, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Heap-based buffer overflow vulnerability in Apache Thrift C++ THeaderTransport.

When an application enables the ZLIB transform for the frames it sends, THeaderTransport::transform() copies the compressed frame into the write buffer without making sure it fits. Data that does not compress, such as content a remote peer supplied, grows under compression, so the copy writes past the end of the heap buffer by an amount that grows with the size of the frame, and for large frames it also reads past the end of the transform buffer.

This issue affects Apache Thrift: before 0.25.0.

Users are recommended to upgrade to version 0.25.0, which fixes the issue.

Weakness: CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2026-91135?

1 open source package ship an affected version, including thrift.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `thrift` | Bitnami | All versions | 0.25.0 |

## How do I fix CVE-2026-91135?

Upgrade thrift to 0.25.0 or later.

## Is CVE-2026-91135 being exploited?

There is no known exploitation of CVE-2026-91135 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-91135 and fix it if it is affected.

What it is: CVE-2026-91135 is a critical memory corruption vulnerability in Apache Thrift, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-91135 in the wild and no public exploit code.

Affected packages and fixed versions:
- thrift (Bitnami): affected all versions; fixed in 0.25.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-91135/ (Markdown: https://insights.sbomify.com/CVE-2026-91135/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-91135
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-91135
- OSV: https://osv.dev/vulnerability/CVE-2026-91135

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-91135/
Summaries are generated and may contain mistakes; the official description above is the record.
