# CVE-2026-91137: Apache Thrift: PHP `thrift_protocol` accelerator: zero-byte container elements


- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 2 Oct 2026
- **Updated:** 2 Oct 2026
- **Also known as:** AZL-106620, BIT-thrift-2026-91137, DEBIAN-CVE-2026-91137, ECHO-d8cd-76f2-90ce, GHSA-r276-xrw4-gpgm, MINI-j92h-r3fp-qg9h, UBUNTU-CVE-2026-91137

## What is CVE-2026-91137?

CVE-2026-91137 is a high-severity vulnerability in Apache Thrift, published on 2 Oct 2026. 

### Official description

Improper validation of specified quantity in input, Allocation of resources without limits or throttling, Excessive Iteration vulnerability in Apache Thrift PHP bindings.

This issue affects Apache Thrift: before 0.25.0.

Users are recommended to upgrade to version 0.25.0, which fixes the issue.

Weakness: CWE-834 (Excessive Iteration), CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-1284 (Improper Validation of Specified Quantity in Input)

## Which versions are affected by CVE-2026-91137?

1 open source package ship an affected version, including thrift.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `thrift` | Bitnami | All versions | 0.25.0 |

## How do I fix CVE-2026-91137?

Upgrade thrift to 0.25.0 or later.

## Is CVE-2026-91137 being exploited?

There is no known exploitation of CVE-2026-91137 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-91137 and fix it if it is affected.

What it is: CVE-2026-91137 is a high-severity vulnerability in Apache Thrift, published on 2 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-91137 in the wild and no public exploit code.

Affected packages and fixed versions:
- thrift (Bitnami): affected all versions; fixed in 0.25.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-91137/ (Markdown: https://insights.sbomify.com/CVE-2026-91137/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-91137
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-91137
- OSV: https://osv.dev/vulnerability/CVE-2026-91137

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-91137/
Summaries are generated and may contain mistakes; the official description above is the record.
