# CVE-2026-91156: Discourse: Chat MessageBus delivers read-restricted messages to unauthorized users

> An authenticated user can view live chat messages from restricted categories via MessageBus despite lacking Chat permissions, exposing sensitive content.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Oct 2026
- **Updated:** 14 Oct 2026
- **Also known as:** BIT-discourse-2026-91156, GHSA-gh4f-qr62-vx8q

## What is CVE-2026-91156?

CVE-2026-91156 is a high-severity missing authorization vulnerability in discourse, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Discourse is an open-source discussion platform. Prior to 2026.9.0, 2026.8.1, 2026.7.3, and 2026.1.9, MessageBus audience calculation could deliver messages from a read-restricted category chat channel to an authenticated user who could view the category but was not allowed to use Chat under the site's group restrictions. The publication path bounded events by category visibility without also enforcing Chat eligibility, exposing live and recent message content available in the MessageBus backlog. The issue does not permit retrieval of the channel's full history through the Chat API and does not permit message creation or modification. This issue is fixed in versions 2026.9.0, 2026.8.1, 2026.7.3, and 2026.1.9.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-91156?

1 open source package ship an affected version, including discourse.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 2026.1.9, 2026.7.3, 2026.8.1, 2026.9.0 |

## How do I fix CVE-2026-91156?

Upgrade discourse to a fixed version for your release line: 2026.1.9, 2026.7.3, 2026.8.1 or 2026.9.0.

## Is CVE-2026-91156 being exploited?

There is no known exploitation of CVE-2026-91156 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-91156 and fix it if it is affected.

What it is: CVE-2026-91156 is a high-severity missing authorization vulnerability in discourse, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-91156 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 2026.1.9, 2026.7.3, 2026.8.1, 2026.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-91156/ (Markdown: https://insights.sbomify.com/CVE-2026-91156/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-91156
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-91156
- OSV: https://osv.dev/vulnerability/CVE-2026-91156

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-91156/
Summaries are generated and may contain mistakes; the official description above is the record.
