# CVE-2026-91157: Discourse: Media uploads remain publicly accessible after category permissions are restricted

> Attackers can access restricted media uploads via public URLs if category permissions change, exposing private data in Discourse forums.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Oct 2026
- **Updated:** 20 Oct 2026
- **Also known as:** BIT-discourse-2026-91157, GHSA-298h-xgw6-4pv3

## What is CVE-2026-91157?

CVE-2026-91157 is a high-severity missing authorization vulnerability in discourse, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Discourse is an open-source discussion platform. Prior to 2026.9.0, 2026.8.1, 2026.7.3, and 2026.1.9, sites with secure uploads enabled did not reconcile existing upload security metadata when a previously public category became read-restricted or when category permissions changed during a bulk import. Media and attachments uploaded while the category was public retained a public accessibility flag and remained reachable by anonymous users through their short upload URLs, including uploads associated with deleted topics. This issue is fixed in versions 2026.9.0, 2026.8.1, 2026.7.3, and 2026.1.9.

Weakness: CWE-863 (Incorrect Authorization), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-91157?

1 open source package ship an affected version, including discourse.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 2026.1.9, 2026.7.3, 2026.8.1, 2026.9.0 |

## How do I fix CVE-2026-91157?

Upgrade discourse to a fixed version for your release line: 2026.1.9, 2026.7.3, 2026.8.1 or 2026.9.0.

## Is CVE-2026-91157 being exploited?

There is no known exploitation of CVE-2026-91157 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-91157 and fix it if it is affected.

What it is: CVE-2026-91157 is a high-severity missing authorization vulnerability in discourse, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-91157 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 2026.1.9, 2026.7.3, 2026.8.1, 2026.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-91157/ (Markdown: https://insights.sbomify.com/CVE-2026-91157/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-91157
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-91157
- OSV: https://osv.dev/vulnerability/CVE-2026-91157

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-91157/
Summaries are generated and may contain mistakes; the official description above is the record.
