CVE-2026-91159 Discourse: Stored oEmbed HTML injection via allowed iframe
Attackers can inject malicious HTML via oEmbed iframes to create misleading UI overlays in Discourse posts, requiring an allowlisted iframe source.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-91159?
CVE-2026-91159 is a high-severity cross-site scripting vulnerability in discourse, published on 14 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Discourse is an open-source discussion platform. Prior to 2026.9.0, 2026.8.1, 2026.7.3, and 2026.1.9, oEmbed processing treated an entire attacker-controlled HTML fragment as trusted when the fragment contained an iframe whose source matched the configured allowlist. A user with posting permission who controlled a public webpage and its oEmbed response could combine an allowlisted iframe with unrelated sibling HTML or CSS, causing stored visual overlays or other styled content to appear in post content and enabling misleading or fraudulent user interfaces. Exploitation requires a posting account, control of the fetched webpage and oEmbed response, and an allowlisted iframe source. The issue affects content integrity but does not expose restricted data, disrupt availability, or require interaction with Discourse Content Security Policy. This issue is fixed in versions 2026.9.0, 2026.8.1, 2026.7.3, and 2026.1.9.
Weakness: CWE-79
Which versions are affected by CVE-2026-91159?
1 open source package ship an affected version, including discourse.
| Package | Affected | Fixed in |
|---|---|---|
discourse Bitnami | All versions | 2026.1.9, 2026.7.3, 2026.8.1, 2026.9.0 |
How do I fix CVE-2026-91159?
Upgrade discourse to a fixed version for your release line: 2026.1.9, 2026.7.3, 2026.8.1 or 2026.9.0.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-91159 being exploited?
There is no known exploitation of CVE-2026-91159 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Sources
Also known as BIT-discourse-2026-91159, GHSA-f9jx-vv33-4282.