{"answers":{"affected":"1 open source package ship an affected version, including discourse.","exploited":"There is no known exploitation of CVE-2026-91159 in the wild and no public exploit code.","fix":"Upgrade discourse to a fixed version for your release line: 2026.1.9, 2026.7.3, 2026.8.1 or 2026.9.0.","what":"CVE-2026-91159 is a high-severity cross-site scripting vulnerability in discourse, published on 14 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-91159 and fix it if it is affected.\n\nWhat it is: CVE-2026-91159 is a high-severity cross-site scripting vulnerability in discourse, published on 14 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-91159 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- discourse (Bitnami): affected all versions; fixed in 2026.1.9, 2026.7.3, 2026.8.1, 2026.9.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-91159/ (Markdown: https://insights.sbomify.com/CVE-2026-91159/index.md)","id":"CVE-2026-91159","markdown":"https://insights.sbomify.com/CVE-2026-91159/index.md","name":"CVE-2026-91159","record":{"aliases":["BIT-discourse-2026-91159","GHSA-f9jx-vv33-4282"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Discourse forum","requires_auth":"low_privilege","summary":"Attackers can inject malicious HTML via oEmbed iframes to create misleading UI overlays in Discourse posts, requiring an allowlisted iframe source.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Discourse is an open-source discussion platform. Prior to 2026.9.0, 2026.8.1, 2026.7.3, and 2026.1.9, oEmbed processing treated an entire attacker-controlled HTML fragment as trusted when the fragment contained an iframe whose source matched the configured allowlist. A user with posting permission who controlled a public webpage and its oEmbed response could combine an allowlisted iframe with unrelated sibling HTML or CSS, causing stored visual overlays or other styled content to appear in post content and enabling misleading or fraudulent user interfaces. Exploitation requires a posting account, control of the fetched webpage and oEmbed response, and an allowlisted iframe source. The issue affects content integrity but does not expose restricted data, disrupt availability, or require interaction with Discourse Content Security Policy. This issue is fixed in versions 2026.9.0, 2026.8.1, 2026.7.3, and 2026.1.9.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":"2026-09-30","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-09-30T20:12:13Z","kind":"github_poc","ref":"https://github.com/sl4x0/autheo-cve-2026-91159-poc","stars":0,"title":"Security PoC payload host for CVE-2026-91159 oEmbed test (authorized bug bounty)"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Discourse: Stored oEmbed HTML injection via allowed iframe","id":"CVE-2026-91159","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":1,"n_references":5,"next":{"headline":"OpenWA: A read-only API key can receive a session pairing QR over the WebSocket event stream","id":"CVE-2026-91160"},"packages":[{"ecosystem":"Bitnami","fixed":["2026.1.9","2026.7.3","2026.8.1","2026.9.0"],"introduced":["0","2026.7.0","2026.8.0","2026.8.99"],"last_affected":[],"package":"discourse","purl":"pkg:bitnami/discourse","source":"BIT-discourse-2026-91159"}],"prev":{"headline":"Discourse: Media uploads remain publicly accessible after category permissions are restricted","id":"CVE-2026-91157"},"products":["discourse"],"published":"2026-10-14","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-20","vendors":["discourse"]},"summary":"Attackers can inject malicious HTML via oEmbed iframes to create misleading UI overlays in Discourse posts, requiring an allowlisted iframe source.","url":"https://insights.sbomify.com/CVE-2026-91159/"}