# CVE-2026-91159: Discourse: Stored oEmbed HTML injection via allowed iframe

> Attackers can inject malicious HTML via oEmbed iframes to create misleading UI overlays in Discourse posts, requiring an allowlisted iframe source.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Oct 2026
- **Updated:** 20 Oct 2026
- **Also known as:** BIT-discourse-2026-91159, GHSA-f9jx-vv33-4282

## What is CVE-2026-91159?

CVE-2026-91159 is a high-severity cross-site scripting vulnerability in discourse, published on 14 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Discourse is an open-source discussion platform. Prior to 2026.9.0, 2026.8.1, 2026.7.3, and 2026.1.9, oEmbed processing treated an entire attacker-controlled HTML fragment as trusted when the fragment contained an iframe whose source matched the configured allowlist. A user with posting permission who controlled a public webpage and its oEmbed response could combine an allowlisted iframe with unrelated sibling HTML or CSS, causing stored visual overlays or other styled content to appear in post content and enabling misleading or fraudulent user interfaces. Exploitation requires a posting account, control of the fetched webpage and oEmbed response, and an allowlisted iframe source. The issue affects content integrity but does not expose restricted data, disrupt availability, or require interaction with Discourse Content Security Policy. This issue is fixed in versions 2026.9.0, 2026.8.1, 2026.7.3, and 2026.1.9.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-91159?

1 open source package ship an affected version, including discourse.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 2026.1.9, 2026.7.3, 2026.8.1, 2026.9.0 |

## How do I fix CVE-2026-91159?

Upgrade discourse to a fixed version for your release line: 2026.1.9, 2026.7.3, 2026.8.1 or 2026.9.0.

## Is CVE-2026-91159 being exploited?

There is no known exploitation of CVE-2026-91159 in the wild and no public exploit code.

Public exploit code:

- Security PoC payload host for CVE-2026-91159 oEmbed test (authorized bug bounty) (github_poc): https://github.com/sl4x0/autheo-cve-2026-91159-poc

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-91159 and fix it if it is affected.

What it is: CVE-2026-91159 is a high-severity cross-site scripting vulnerability in discourse, published on 14 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-91159 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 2026.1.9, 2026.7.3, 2026.8.1, 2026.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-91159/ (Markdown: https://insights.sbomify.com/CVE-2026-91159/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-91159
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-91159
- OSV: https://osv.dev/vulnerability/CVE-2026-91159

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-91159/
Summaries are generated and may contain mistakes; the official description above is the record.
