# CVE-2026-91161: OpenWA: VIEWER API keys can read WhatsApp group invite codes

> Attackers with VIEWER keys can retrieve WhatsApp group invite codes, allowing unauthorized accounts to join and access administered groups.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 24 Sep 2026
- **Updated:** 5 Oct 2026
- **Also known as:** GHSA-45fh-xj7x-vj2x

## What is CVE-2026-91161?

CVE-2026-91161 is a medium-severity missing authorization vulnerability in rmyndharis OpenWA, published on 24 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenWA is a free, open source, self-hosted WhatsApp API gateway. Prior to 0.23.5, the GET /api/sessions/{sessionId}/groups/{groupId}/invite-code endpoint and the GroupGetInviteCode MCP tool have no OPERATOR role requirement, allowing a valid VIEWER key scoped to a session to retrieve an active group invite code. The invite code is a transferable WhatsApp bearer capability, so an external account can join a group administered by the session without an OpenWA credential, gain read and post access to the group, and retain membership after the VIEWER key is revoked. Affected deployments are those that issue VIEWER keys to parties who should not be able to add accounts to administered groups; OPERATOR and ADMIN access is intended. This issue is fixed in version 0.23.5.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-91161?


## How do I fix CVE-2026-91161?

No fix has been published for CVE-2026-91161 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-91161 being exploited?

There is no known exploitation of CVE-2026-91161 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-91161 and fix it if it is affected.

What it is: CVE-2026-91161 is a medium-severity missing authorization vulnerability in rmyndharis OpenWA, published on 24 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-91161 in the wild and no public exploit code.

Affected product: rmyndharis OpenWA. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-91161/ (Markdown: https://insights.sbomify.com/CVE-2026-91161/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-91161
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-91161
- OSV: https://osv.dev/vulnerability/CVE-2026-91161

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-91161/
Summaries are generated and may contain mistakes; the official description above is the record.
