# CVE-2026-91167: Missing authorization in warpgate

> Limited administrators can bypass permission boundaries to extend or reinstate role assignments, potentially escalating privileges within the Warpgate bastion host.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 21 Sep 2026
- **Updated:** 22 Sep 2026
- **Also known as:** GHSA-fjgc-484v-j6mf

## What is CVE-2026-91167?

CVE-2026-91167 is a medium-severity missing authorization vulnerability in warp-tech warpgate, published on 21 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Warpgate is an open source SSH, HTTPS and MySQL bastion host for Linux. Prior to 0.28.4, PUT /@warpgate/admin/api/users/:id/roles/:role_id reaches api_update_user_role in warpgate-admin/src/api/users.rs through AdminContext but does not require AdminPermission::AccessRolesAssign. A limited administrator with any permission can update expires_at on an existing UserRoleAssignment and clear revoked_at, extending an expiring grant or reinstating a revoked grant. The endpoint cannot create a role assignment that never existed because it returns not found without a matching user and role pair. This issue is fixed in version 0.28.4.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-91167?


## How do I fix CVE-2026-91167?

No fix has been published for CVE-2026-91167 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-91167 being exploited?

There is no known exploitation of CVE-2026-91167 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-91167 and fix it if it is affected.

What it is: CVE-2026-91167 is a medium-severity missing authorization vulnerability in warp-tech warpgate, published on 21 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-91167 in the wild and no public exploit code.

Affected product: warp-tech warpgate. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-91167/ (Markdown: https://insights.sbomify.com/CVE-2026-91167/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-91167
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-91167
- OSV: https://osv.dev/vulnerability/CVE-2026-91167

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-91167/
Summaries are generated and may contain mistakes; the official description above is the record.
