{"answers":{"affected":"1 open source package ship an affected version, including nginx-gateway-fabric.","exploited":"There is no known exploitation of CVE-2026-91184 in the wild and no public exploit code.","fix":"Upgrade nginx-gateway-fabric to 2.8.0 or later.","what":"CVE-2026-91184 is a high-severity code injection vulnerability in F5 NGINX Gateway Fabric, published on 14 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-91184 and fix it if it is affected.\n\nWhat it is: CVE-2026-91184 is a high-severity code injection vulnerability in F5 NGINX Gateway Fabric, published on 14 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-91184 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nginx-gateway-fabric (Bitnami): affected from 2.4.0; fixed in 2.8.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-91184/ (Markdown: https://insights.sbomify.com/CVE-2026-91184/index.md)","id":"CVE-2026-91184","markdown":"https://insights.sbomify.com/CVE-2026-91184/index.md","name":"CVE-2026-91184","record":{"aliases":["BIT-nginx-gateway-fabric-2026-91184","GHSA-8rxj-rxx8-xj47"],"analysis":{"component_type":"cloud_service","fix_type":"patch","impacts":["data_read","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"NGINX Gateway Fabric","requires_auth":"low_privilege","summary":"Authenticated attackers can inject NGINX directives via AuthenticationFilter CRDs to read secrets, perform SSRF, or hijack routes in shared gateways.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"f5","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-76","name":"Improper Neutralization of Equivalent Special Elements"}],"description":"Description\n\nNGINX Gateway Fabric has a vulnerability when it renders the spec.basic.realm (and spec.jwt.realm) field of a namespaced AuthenticationFilter verbatim, unescaped and unvalidated, into the shared data-plane nginx.conf as auth_basic \"\u003crealm\u003e\";. A namespaced authenticated attacker that configures AuthenticationFilter CRD to an HTTPRoute/GRPCRoute on a shared Gateway can craft a realm value that closes the quoted directive and the enclosing location {} block and injects arbitrary NGINX directives into that Gateway's data-plane config. \n\nImpact\n\nA remote authenticated attacker can send crafted requests to configure NGINX Gateway Fabric AuthenticationFilter CRD and may be able to read every co-located tenant's mounted secrets, SSRF via proxy_pass, reading the pod ServiceAccount token, or hijacking other tenants' routes. There is no data plane exposure; this is a control plane issue only.\n\nNote: Software versions which have reached End of Technical Support (EoTS) are not evaluated.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"NGINX Gateway Fabric vulnerability","id":"CVE-2026-91184","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"PNG decoder: a duplicate IHDR chunk after IDAT resizes the image after allocation, causing a heap out-of-bounds write","id":"CVE-2026-91186"},"packages":[{"ecosystem":"Bitnami","fixed":["2.8.0"],"introduced":["2.4.0"],"last_affected":[],"package":"nginx-gateway-fabric","purl":"pkg:bitnami/nginx-gateway-fabric","source":"BIT-nginx-gateway-fabric-2026-91184"}],"prev":{"headline":"Data Retention Teams Endpoint Leaks Private Team Invite ID","id":"CVE-2026-91181"},"products":["NGINX Gateway Fabric"],"published":"2026-10-14","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-15","vendors":["F5"]},"summary":"Authenticated attackers can inject NGINX directives via AuthenticationFilter CRDs to read secrets, perform SSRF, or hijack routes in shared gateways.","url":"https://insights.sbomify.com/CVE-2026-91184/"}