# CVE-2026-91184: NGINX Gateway Fabric vulnerability

> Authenticated attackers can inject NGINX directives via AuthenticationFilter CRDs to read secrets, perform SSRF, or hijack routes in shared gateways.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Oct 2026
- **Updated:** 15 Oct 2026
- **Also known as:** BIT-nginx-gateway-fabric-2026-91184, GHSA-8rxj-rxx8-xj47

## What is CVE-2026-91184?

CVE-2026-91184 is a high-severity code injection vulnerability in F5 NGINX Gateway Fabric, published on 14 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Description

NGINX Gateway Fabric has a vulnerability when it renders the spec.basic.realm (and spec.jwt.realm) field of a namespaced AuthenticationFilter verbatim, unescaped and unvalidated, into the shared data-plane nginx.conf as auth_basic "<realm>";. A namespaced authenticated attacker that configures AuthenticationFilter CRD to an HTTPRoute/GRPCRoute on a shared Gateway can craft a realm value that closes the quoted directive and the enclosing location {} block and injects arbitrary NGINX directives into that Gateway's data-plane config. 

Impact

A remote authenticated attacker can send crafted requests to configure NGINX Gateway Fabric AuthenticationFilter CRD and may be able to read every co-located tenant's mounted secrets, SSRF via proxy_pass, reading the pod ServiceAccount token, or hijacking other tenants' routes. There is no data plane exposure; this is a control plane issue only.

Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

Weakness: CWE-76 (Improper Neutralization of Equivalent Special Elements)

## Which versions are affected by CVE-2026-91184?

1 open source package ship an affected version, including nginx-gateway-fabric.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nginx-gateway-fabric` | Bitnami | From 2.4.0 | 2.8.0 |

## How do I fix CVE-2026-91184?

Upgrade nginx-gateway-fabric to 2.8.0 or later.

## Is CVE-2026-91184 being exploited?

There is no known exploitation of CVE-2026-91184 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-91184 and fix it if it is affected.

What it is: CVE-2026-91184 is a high-severity code injection vulnerability in F5 NGINX Gateway Fabric, published on 14 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-91184 in the wild and no public exploit code.

Affected packages and fixed versions:
- nginx-gateway-fabric (Bitnami): affected from 2.4.0; fixed in 2.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-91184/ (Markdown: https://insights.sbomify.com/CVE-2026-91184/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-91184
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-91184
- OSV: https://osv.dev/vulnerability/CVE-2026-91184

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-91184/
Summaries are generated and may contain mistakes; the official description above is the record.
