CVE-2026-91206 Apache Roller: Reflected XSS in the optional LDAP comment authenticator

Medium 6.1 Published Updated

Remote attackers can execute arbitrary scripts via reflected XSS in the optional LDAP comment authenticator, requiring specific configuration and user interaction.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2026-91206?

CVE-2026-91206 is a medium-severity cross-site scripting vulnerability in Apache Roller, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in Apache Roller 6.1.5 allows a remote attacker to perform reflected cross-site scripting through the optional LDAP comment authenticator, which writes request parameter values into its HTML form without escaping. This affects only sites configured to use LdapCommentAuthenticator, and a victim whose session has already loaded the authenticator form must follow a crafted link. Users are recommended to upgrade to Apache Roller 6.1.6 or later, which escapes the reflected values.

Weakness: CWE-79

Which versions are affected by CVE-2026-91206?

How do I fix CVE-2026-91206?

No fix has been published for CVE-2026-91206 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-91206 being exploited?

There is no known exploitation of CVE-2026-91206 in the wild and no public exploit code.

Sources

Also known as GHSA-v625-qw46-3c92.

Is CVE-2026-91206 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free