# CVE-2026-91206: Apache Roller: Reflected XSS in the optional LDAP comment authenticator

> Remote attackers can execute arbitrary scripts via reflected XSS in the optional LDAP comment authenticator, requiring specific configuration and user interaction.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 28 Sep 2026
- **Updated:** 30 Sep 2026
- **Also known as:** GHSA-v625-qw46-3c92

## What is CVE-2026-91206?

CVE-2026-91206 is a medium-severity cross-site scripting vulnerability in Apache Roller, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in Apache Roller 6.1.5 allows a remote attacker to perform reflected cross-site scripting through the optional LDAP comment authenticator, which writes request parameter values into its HTML form without escaping. This affects only sites configured to use LdapCommentAuthenticator, and a victim whose session has already loaded the authenticator form must follow a crafted link. Users are recommended to upgrade to Apache Roller 6.1.6 or later, which escapes the reflected values.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-91206?


## How do I fix CVE-2026-91206?

No fix has been published for CVE-2026-91206 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-91206 being exploited?

There is no known exploitation of CVE-2026-91206 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-91206 and fix it if it is affected.

What it is: CVE-2026-91206 is a medium-severity cross-site scripting vulnerability in Apache Roller, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-91206 in the wild and no public exploit code.

Affected product: Apache Roller. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-91206/ (Markdown: https://insights.sbomify.com/CVE-2026-91206/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-91206
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-91206
- OSV: https://osv.dev/vulnerability/CVE-2026-91206

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-91206/
Summaries are generated and may contain mistakes; the official description above is the record.
