{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-9133 exists.","fix":"No fix has been published for CVE-2026-9133 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-9133 is a high-severity vulnerability in RabbitMQ AWS, published on 20 May 2026."},"fix_prompt":"Check this codebase for CVE-2026-9133 and fix it if it is affected.\n\nWhat it is: CVE-2026-9133 is a high-severity vulnerability in RabbitMQ AWS, published on 20 May 2026. \nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-9133 exists.\n\nAffected product: RabbitMQ AWS. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-9133/ (Markdown: https://insights.sbomify.com/CVE-2026-9133/index.md)","id":"CVE-2026-9133","markdown":"https://insights.sbomify.com/CVE-2026-9133/index.md","name":"CVE-2026-9133","record":{"aliases":["GHSA-8554-wg4r-7hxm"],"analysis":null,"analysis_generated_by":null,"assigner":"AMZN","cpe":[],"cvss":{"score":8.3,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-489","name":"Active Debug Code"}],"description":"Active debug code exists in the ARN resolver of amazon-mq rabbitmq-aws before version 0.2.1. A debug ARN scheme (arn:aws-debug:file) accepted by the PUT /api/aws/arn/validate validation endpoint might allow remote authenticated users to perform arbitrary file reads on any file accessible to the RabbitMQ process. \n\nTo remediate this issue, customers should upgrade to version 0.2.1 of rabbitmq-aws. If RabbitMQ is configured to use TLS for connections, we also recommend rotating any associated private certificate keys.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":1,"refs":[{"date":null,"kind":"nuclei","ref":"http/cves/2026/CVE-2026-9133.yaml","stars":null,"title":"Amazon rabbitmq-aws 0.1.0 through 0.2.0 - Arbitrary File Read"}],"tier":"weaponised"},"has_fix":false,"headline":"Arbitrary file read in rabbitmq-aws plugin","id":"CVE-2026-9133","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":null,"year":"2026"},"n_packages":0,"n_references":3,"next":{"headline":"Cross-site scripting in Photo Gallery by FooGallery : Responsive Image Gallery, Masonry Gallery \u0026 Carousel","id":"CVE-2026-9134"},"packages":[],"prev":{"headline":"Missing authorization in Enterprise Server","id":"CVE-2026-9132"},"products":["RabbitMQ AWS"],"published":"2026-05-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-21","vendors":["AWS"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2026-9133/"}