# CVE-2026-9133: Arbitrary file read in rabbitmq-aws plugin


- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 20 May 2026
- **Updated:** 21 May 2026
- **Also known as:** GHSA-8554-wg4r-7hxm

## What is CVE-2026-9133?

CVE-2026-9133 is a high-severity vulnerability in RabbitMQ AWS, published on 20 May 2026. 

### Official description

Active debug code exists in the ARN resolver of amazon-mq rabbitmq-aws before version 0.2.1. A debug ARN scheme (arn:aws-debug:file) accepted by the PUT /api/aws/arn/validate validation endpoint might allow remote authenticated users to perform arbitrary file reads on any file accessible to the RabbitMQ process. 

To remediate this issue, customers should upgrade to version 0.2.1 of rabbitmq-aws. If RabbitMQ is configured to use TLS for connections, we also recommend rotating any associated private certificate keys.

Weakness: CWE-489 (Active Debug Code)

## Which versions are affected by CVE-2026-9133?


## How do I fix CVE-2026-9133?

No fix has been published for CVE-2026-9133 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-9133 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-9133 exists.

Public exploit code:

- Amazon rabbitmq-aws 0.1.0 through 0.2.0 - Arbitrary File Read (nuclei): http/cves/2026/CVE-2026-9133.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-9133 and fix it if it is affected.

What it is: CVE-2026-9133 is a high-severity vulnerability in RabbitMQ AWS, published on 20 May 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-9133 exists.

Affected product: RabbitMQ AWS. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-9133/ (Markdown: https://insights.sbomify.com/CVE-2026-9133/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-9133
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-9133
- OSV: https://osv.dev/vulnerability/CVE-2026-9133

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-9133/
Summaries are generated and may contain mistakes; the official description above is the record.
