CVE-2026-9162 Global session revocation does not invalidate active WebSocket connections
Attackers with active WebSocket connections can bypass global session revocation and continue receiving real-time events in Mattermost.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-9162?
CVE-2026-9162 is a medium-severity authentication bypass vulnerability in Mattermost Mattermost Server, published on 22 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 11.7.x <= 11.7.0, 11.6.x <= 11.6.2, 11.5.x <= 11.5.5, 10.11.x <= 10.11.17 fail to invalidate cached authentication state for active WebSocket connections during global session revocation, which allows a user with an existing WebSocket connection to remain authenticated and continue receiving real-time events until the cached session expires or the client reconnects.. Mattermost Advisory ID: MMSA-2026-00664
Weakness: CWE-613
Which versions are affected by CVE-2026-9162?
9 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.18 |
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.18 |
github.com/mattermost/mattermost-server Go | From 10.11.0+incompatible | 10.11.18+incompatible, 11.5.6+incompatible, 11.6.3+incompatible, 11.7.1+incompatible |
github.com/mattermost/mattermost-server Go | From 11.5.0 | 11.5.6 |
github.com/mattermost/mattermost-server Go | From 11.5.0 | 11.5.6 |
github.com/mattermost/mattermost-server Go | From 11.6.0 | 11.6.3 |
3 more packages
github.com/mattermost/mattermost-server Go | From 11.6.0 | 11.6.3 |
github.com/mattermost/mattermost-server Go | From 11.7.0 | 11.7.1 |
github.com/mattermost/mattermost-server Go | From 11.7.0 | 11.7.1 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2026-9162?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.11.18, 10.11.18+incompatible, 11.5.6+incompatible or 11.6.3+incompatible.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-9162 being exploited?
There is no known exploitation of CVE-2026-9162 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-h998-hxxj-8q83, GO-2026-6482.