# CVE-2026-91968: vikunja before 2.6.0 Denial of Service via unbounded filter recursion

> Authenticated attackers can cause denial of service in Vikunja by submitting deeply nested filter expressions that exhaust server memory.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 15 Sep 2026
- **Also known as:** GHSA-xxc3-xpmc-vmvr, GO-2026-6759

## What is CVE-2026-91968?

CVE-2026-91968 is a high-severity denial of service vulnerability in go-vikunja vikunja, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

vikunja versions before 2.6.0 contain a resource exhaustion vulnerability in the task-filter endpoint that accepts deeply nested filter expressions without recursion depth limits. Authenticated attackers can supply thousands of nested parentheses in the filter query parameter to exhaust memory and terminate the API process.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2026-91968?

3 open source packages ship an affected version, including code.vikunja.io/api.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `code.vikunja.io/api` | Go | All versions | None |
| `code.vikunja.io/api` | Go | From 2.5.0 | 2.6.0 |
| `code.vikunja.io/api` | Go | From 2.5.0 | 2.6.0 |

## How do I fix CVE-2026-91968?

Upgrade code.vikunja.io/api to 2.6.0 or later.

## Is CVE-2026-91968 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-91968 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-91968 and fix it if it is affected.

What it is: CVE-2026-91968 is a high-severity denial of service vulnerability in go-vikunja vikunja, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-91968 exists.

Affected packages and fixed versions:
- code.vikunja.io/api (Go): affected all versions; no fix listed
- code.vikunja.io/api (Go): affected from 2.5.0; fixed in 2.6.0
- code.vikunja.io/api (Go): affected from 2.5.0; fixed in 2.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-91968/ (Markdown: https://insights.sbomify.com/CVE-2026-91968/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-91968
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-91968
- OSV: https://osv.dev/vulnerability/CVE-2026-91968

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-91968/
Summaries are generated and may contain mistakes; the official description above is the record.
