# CVE-2026-91979: Vikunja before 2.6.0 Denial of Service via Decompression Bomb

> Authenticated users can crash the Vikunja instance by uploading decompression bombs during data import, exhausting server resources.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** GHSA-w7jp-mf2v-8342, GO-2026-6756

## What is CVE-2026-91979?

CVE-2026-91979 is a high-severity denial of service vulnerability in go-vikunja vikunja, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Vikunja before 2.6.0 fails to limit archive expansion during data import, allowing authenticated users to cause denial of service. Attackers can upload highly compressed files that expand to tens of gigabytes in memory and disk, exhausting server resources and crashing the instance.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-91979?

3 open source packages ship an affected version, including code.vikunja.io/api.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `code.vikunja.io/api` | Go | All versions | None |
| `code.vikunja.io/api` | Go | All versions | 2.6.0 |
| `code.vikunja.io/api` | Go | All versions | 2.6.0 |

## How do I fix CVE-2026-91979?

Upgrade code.vikunja.io/api to 2.6.0 or later.

## Is CVE-2026-91979 being exploited?

There is no known exploitation of CVE-2026-91979 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-91979 and fix it if it is affected.

What it is: CVE-2026-91979 is a high-severity denial of service vulnerability in go-vikunja vikunja, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-91979 in the wild and no public exploit code.

Affected packages and fixed versions:
- code.vikunja.io/api (Go): affected all versions; no fix listed
- code.vikunja.io/api (Go): affected all versions; fixed in 2.6.0
- code.vikunja.io/api (Go): affected all versions; fixed in 2.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-91979/ (Markdown: https://insights.sbomify.com/CVE-2026-91979/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-91979
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-91979
- OSV: https://osv.dev/vulnerability/CVE-2026-91979

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-91979/
Summaries are generated and may contain mistakes; the official description above is the record.
