# CVE-2026-91981: Vikunja before 2.6.0 User Enumeration via v2 API

> Attackers with read-only share links can enumerate project users and confirm arbitrary usernames via the v2 API.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 21 Sep 2026
- **Also known as:** GHSA-vfxw-3x8p-2vjr, GO-2026-6752

## What is CVE-2026-91981?

CVE-2026-91981 is a medium-severity vulnerability in go-vikunja vikunja, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Vikunja versions before 2.6.0 fail to properly validate link-share tokens in the v2 API user search endpoints. Attackers with a read-only share link can enumerate project users via the projects endpoint and confirm arbitrary usernames exist via the global search endpoint.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-91981?

3 open source packages ship an affected version, including code.vikunja.io/api.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `code.vikunja.io/api` | Go | All versions | None |
| `code.vikunja.io/api` | Go | All versions | 2.6.0 |
| `code.vikunja.io/api` | Go | All versions | 2.6.0 |

## How do I fix CVE-2026-91981?

Upgrade code.vikunja.io/api to 2.6.0 or later.

## Is CVE-2026-91981 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-91981 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-91981 and fix it if it is affected.

What it is: CVE-2026-91981 is a medium-severity vulnerability in go-vikunja vikunja, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-91981 exists.

Affected packages and fixed versions:
- code.vikunja.io/api (Go): affected all versions; no fix listed
- code.vikunja.io/api (Go): affected all versions; fixed in 2.6.0
- code.vikunja.io/api (Go): affected all versions; fixed in 2.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-91981/ (Markdown: https://insights.sbomify.com/CVE-2026-91981/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-91981
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-91981
- OSV: https://osv.dev/vulnerability/CVE-2026-91981

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-91981/
Summaries are generated and may contain mistakes; the official description above is the record.
