# CVE-2026-91985: Vikunja before 2.6.0 Privilege Escalation via Link Share Hash

> Read-only members can obtain link-share secrets to escalate privileges and perform unauthorized writes or administrative actions in Vikunja.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 15 Sep 2026
- **Also known as:** GHSA-qfwc-vx6f-3g6g, GO-2026-6747

## What is CVE-2026-91985?

CVE-2026-91985 is a high-severity vulnerability in go-vikunja vikunja, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vikunja before 2.6.0 fails to properly restrict access to the link-share hash field in single-share read endpoints, allowing read-only members to obtain the share's secret credential. Attackers can exchange the disclosed hash for a link-share JWT at the share's permission level to escalate privileges and perform unauthorized writes or administrative actions.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-91985?

3 open source packages ship an affected version, including code.vikunja.io/api.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `code.vikunja.io/api` | Go | All versions | None |
| `code.vikunja.io/api` | Go | All versions | 2.6.0 |
| `code.vikunja.io/api` | Go | All versions | 2.6.0 |

## How do I fix CVE-2026-91985?

Upgrade code.vikunja.io/api to 2.6.0 or later.

## Is CVE-2026-91985 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-91985 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-91985 and fix it if it is affected.

What it is: CVE-2026-91985 is a high-severity vulnerability in go-vikunja vikunja, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-91985 exists.

Affected packages and fixed versions:
- code.vikunja.io/api (Go): affected all versions; no fix listed
- code.vikunja.io/api (Go): affected all versions; fixed in 2.6.0
- code.vikunja.io/api (Go): affected all versions; fixed in 2.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-91985/ (Markdown: https://insights.sbomify.com/CVE-2026-91985/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-91985
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-91985
- OSV: https://osv.dev/vulnerability/CVE-2026-91985

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-91985/
Summaries are generated and may contain mistakes; the official description above is the record.
