# CVE-2026-91987: atomic-agents-stack before 1.1.0 Cost Guardrail Bypass via Unknown Model

> Attackers can bypass cost guardrails by using unknown model identifiers, allowing them to exceed budget limits in parallel batch operations.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** GHSA-gpqc-jrqh-x9xp, GHSA-j659-8xh6-5pq5

## What is CVE-2026-91987?

CVE-2026-91987 is a high-severity vulnerability in dep0we atomic-agents-stack, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

atomic-agents-stack before 1.1.0 contains a cost-guardrail bypass in the _estimate_batch_cost function that returns zero cost for unknown models not in the pricing table. Attackers can configure deployments with unknown model identifiers to bypass daily cost caps and exceed budget limits in parallel batch operations.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-91987?

2 open source packages ship an affected version, including atomic-agents-stack.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `atomic-agents-stack` | PyPI | All versions | 1.1.0 |
| `atomic-agents-stack` | PyPI | All versions | 1.1.0 |

## How do I fix CVE-2026-91987?

Upgrade atomic-agents-stack to 1.1.0 or later.

## Is CVE-2026-91987 being exploited?

There is no known exploitation of CVE-2026-91987 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-91987 and fix it if it is affected.

What it is: CVE-2026-91987 is a high-severity vulnerability in dep0we atomic-agents-stack, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-91987 in the wild and no public exploit code.

Affected packages and fixed versions:
- atomic-agents-stack (PyPI): affected all versions; fixed in 1.1.0
- atomic-agents-stack (PyPI): affected all versions; fixed in 1.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-91987/ (Markdown: https://insights.sbomify.com/CVE-2026-91987/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-91987
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-91987
- OSV: https://osv.dev/vulnerability/CVE-2026-91987

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-91987/
Summaries are generated and may contain mistakes; the official description above is the record.
