{"answers":{"affected":"2 open source packages ship an affected version, including atomic-agents-stack.","exploited":"There is no known exploitation of CVE-2026-91989 in the wild and no public exploit code.","fix":"Upgrade atomic-agents-stack to 1.1.0 or later.","what":"CVE-2026-91989 is a high-severity path traversal vulnerability in dep0we atomic-agents-stack, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-91989 and fix it if it is affected.\n\nWhat it is: CVE-2026-91989 is a high-severity path traversal vulnerability in dep0we atomic-agents-stack, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-91989 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- atomic-agents-stack (PyPI): affected all versions; fixed in 1.1.0\n- atomic-agents-stack (PyPI): affected all versions; fixed in 1.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-91989/ (Markdown: https://insights.sbomify.com/CVE-2026-91989/index.md)","id":"CVE-2026-91989","markdown":"https://insights.sbomify.com/CVE-2026-91989/index.md","name":"CVE-2026-91989","record":{"aliases":["GHSA-p4ww-qqmg-mcg4","GHSA-rm43-82j9-r4mj"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"atomic-agents-stack dashboard","requires_auth":"none","summary":"Remote attackers can read arbitrary files outside the intended directory by exploiting path traversal in the dashboard HTTP server.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"atomic-agents-stack before 1.1.0 contains a path traversal vulnerability in the dashboard HTTP server that allows remote attackers to read arbitrary files by supplying directory traversal sequences in request paths. Attackers can bypass path containment checks by including '../' segments in requests to the DashboardHandler.do_GET endpoint to access files outside the intended agents_root directory.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"atomic-agents-stack before 1.1.0 Path Traversal via dashboard serve.py","id":"CVE-2026-91989","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Tornado before 6.5.8 Memory Amplification DoS via multipart","id":"CVE-2026-91990"},"packages":[{"ecosystem":"PyPI","fixed":["1.1.0"],"introduced":["0"],"last_affected":[],"package":"atomic-agents-stack","purl":null,"source":"GHSA-rm43-82j9-r4mj"},{"ecosystem":"PyPI","fixed":["1.1.0"],"introduced":["0"],"last_affected":[],"package":"atomic-agents-stack","purl":"pkg:pypi/atomic-agents-stack","source":"GHSA-rm43-82j9-r4mj"}],"prev":{"headline":"atomic-agents-stack before 1.1.0 Remote Code Execution via HTTP MCP","id":"CVE-2026-91988"},"products":["atomic-agents-stack"],"published":"2026-09-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-17","vendors":["dep0we"]},"summary":"Remote attackers can read arbitrary files outside the intended directory by exploiting path traversal in the dashboard HTTP server.","url":"https://insights.sbomify.com/CVE-2026-91989/"}