# CVE-2026-91989: atomic-agents-stack before 1.1.0 Path Traversal via dashboard serve.py

> Remote attackers can read arbitrary files outside the intended directory by exploiting path traversal in the dashboard HTTP server.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** GHSA-p4ww-qqmg-mcg4, GHSA-rm43-82j9-r4mj

## What is CVE-2026-91989?

CVE-2026-91989 is a high-severity path traversal vulnerability in dep0we atomic-agents-stack, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

atomic-agents-stack before 1.1.0 contains a path traversal vulnerability in the dashboard HTTP server that allows remote attackers to read arbitrary files by supplying directory traversal sequences in request paths. Attackers can bypass path containment checks by including '../' segments in requests to the DashboardHandler.do_GET endpoint to access files outside the intended agents_root directory.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-91989?

2 open source packages ship an affected version, including atomic-agents-stack.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `atomic-agents-stack` | PyPI | All versions | 1.1.0 |
| `atomic-agents-stack` | PyPI | All versions | 1.1.0 |

## How do I fix CVE-2026-91989?

Upgrade atomic-agents-stack to 1.1.0 or later.

## Is CVE-2026-91989 being exploited?

There is no known exploitation of CVE-2026-91989 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-91989 and fix it if it is affected.

What it is: CVE-2026-91989 is a high-severity path traversal vulnerability in dep0we atomic-agents-stack, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-91989 in the wild and no public exploit code.

Affected packages and fixed versions:
- atomic-agents-stack (PyPI): affected all versions; fixed in 1.1.0
- atomic-agents-stack (PyPI): affected all versions; fixed in 1.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-91989/ (Markdown: https://insights.sbomify.com/CVE-2026-91989/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-91989
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-91989
- OSV: https://osv.dev/vulnerability/CVE-2026-91989

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-91989/
Summaries are generated and may contain mistakes; the official description above is the record.
